Keyfax issues - Keyfax Notification shut-down

Symptoms

Users report that they receive the message: 'Keyfax has disabled status notifications'.

Which may be followed by the the Keyfax window not closing, and the 'Script Completed' message appearing::

If the user continues clicking on links in the page, an Internet Explorer message may display warning that the context pool is full:

Cause

This problem occurs as a result of the Keyfax OCX used by the host application trying to get 'Session' state from the IIS Server so the browser window can close and focus return to the host application.

The most likely cause of the 'Keyfax has disabled status notifications' message above is because Keyfax users are not using unique user ids. Keyfax relies upon each user using their own ID. Typically, this can happen in a test/workshop environment where multiple users are using the Keyfax Launcher (OCX Testing) program, which, unless altered, will use the default userid 'operator'. This error is less likely to occur (for this reason) in a production environment as the HMS must pass across a unique user id in the startup XML packet.

This behaviour can also occur if the IIS Server running the Keyfax web service is unavailable, not responding or blocking XMLHTTP trafic between the Keyfax32/status.ASP file and the Keyfax32.DLL (dependancy of the Keyfax.OCX or KeyfaxMIS.OCX) used by a host application.

This error can also be associated with shared Citrix or Keyfax user profiles; click here for more details.

Resolution

If the problem persists (it may be a one-off), the solution is normally to reset the IIS service or 'Re-boot' the IIS Server.

To reset the IIS service on a Windows 2000/2003 server:

  1. Click Start, and then click Run.
  2. In the Open box, type iisreset, and then click OK.
  3. A command window will open, displaying the following messages appear:
  4. The command window will close automatically.
  5. Test that the service has reset by calling the Keyfax test container in a browser.

From time to time, the Windows Internet Information Services (IIS) service may get inundated with requests and cause the service to 'hang'. Windows 2003 servers may reset themselves automatically, but Windows 2000 servers will always need a manual reset.

If this still doesn't resolve the issue, you may need to run 'Fix Conflicts' from the Keyfax Console (KFC32). The same can be achieved by running the stored procedure sp_del_sessions against the database invloved.

Status

This behaviour is by design.

Document data
Document Date: 20 April 2006revision 1
Keyfax version : 3.2.0.0
Author: Technical Serviceskeyfax@touch-base.com